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Introduction

Thank you for your interest in the EMCAP (E-mail Collection and Preservation) pilot project. EMCAP is a
software application currently comprised of several custom modules; one of the modules is for those
users designated to have archival e-mail messages worthy of long-term preservation. The remaining
modules are for those responsible for the capture and transformation of the archival e-mail messages.

Users designated to archive their e-mail will be given a second e-mail account on an archival e-mail
server dedicated to collecting and storing archival mail. This archival e-mail account appears as an
additional folder (or “archive” folder) within the e-mail client to collect messages that the user has
organized and designated to be archival based on the messages’ content and by using his or her
agency’s records retention and disposition schedule to identify what messages should be permanently
retained. The additional e-mail account in an e-mail client is treated just like another folder in which to
copy and store archival messages. The user can also check on the status of the archival e-mail messages
and make basic changes to his/her account via the EMCAP Status Account module.

Each user is provided with a User Guide that covers how to archive e-mails using the tool in accordance
with his or her agency’s records retention and disposition schedule as well as how to make
administrative changes through the Status Account tool. Since this is a pilot project, some aspects may
be different than when EMCAP goes into production as a permanent e-mail archiving tool.

The EMCAP Server Administrative Console (or Admin Console) provides a central place to monitor and
control the action of the Core Processing Engine (which processes the e-mail messages), maintain the
list of domains and accounts that will be processed, and launch various other utilities. The Admin
Console modules allow EMCAP administrators to manage individual and domain user accounts, including
creating, editing, deleting or closing user accounts. The console also allows administrators to manage
the processes required to collect and preserve e-mail messages with long-term value/high public
interest, including importing and processing data files (produced using Microsoft data files which have a
Personal Storage Table [.pst] extension). Processing e-mail messages transforms them from its native
format to a non-proprietary and stable XML “preservation copy”.

This User Guide covers how to effectively use the Server Administrative Console.

Additional information about this grant project can be found at:
http://www.ah.dcr.state.nc.us/records/EmailPreservation.

Guide Layout

There are two primary ways to receive archival e-mail messages: (1) current users actively upload
archival e-mail messages to the archival server via Internet Message Access Protocol (IMAP), or (2) an
employee’s e-mail messages (which are regarded as archival) are removed from his/her computer’s hard
drive as Microsoft Outlook data (.pst) files and are transferred to the repository via a digital storage
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medium. In this scenario, the .pst files are not available for processing in the same manner as those
copied or moved directly to the archival server by the user. As such, this guide addresses these two
types of users separately.

The first section offers guidance on managing active EMCAP users. It covers setting up new user
accounts and editing current user accounts. The second section offers guidance on handling those
situations involving .pst data files. It covers copying and importing .pst files into the archival server and
creating new user accounts to accept the imported files.

While this guide covers these two scenarios separately, the manners in which archival e-mail messages
are parsed and transformed to XML are identical. Therefore, the last section covering processing of the
e-mail messages will apply to both situations.

Lastly, you will notice the @ symbol throughout the Guide. This symbol highlights hints and shortcuts
when using the different utilities, and any special circumstances that you should pay close attention to.

Managing Active EMCAP Users

Logging Into the EMCAP Administrative Console

Each person who will administer EMCAP must do by establishing a Remote Desktop Connection to the
EMCAP Server. The account user should have full administrative privileges for the EMCAP Server (i.e.,
the account should be a member of the local administrators group). Please ask your IT department to
enable Remote Desktop Connections to the server and to make sure that you have an account that has
the necessary privileges.

From the main toolbar on your desktop, click on the Start button, and select All Programs -
Accessories > Remote Desktop Connection. A Remote Desktop Connection window will appear.

From the dropdown list, select the appropriate Internet Protocol (IP) address of the remote computer
(this address will be determined by your IT network administrator) and then click the Connect button.

AER|

wd Jlappei= Lasien e Qop=e i)

IP Address

[ Connect ] Cancel H Help H Options

Computer; 146.135.6.193
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@ For easier access and login to the remote desktop, simply drop and drag the remote desktop icon
onto your desktop.

The Log On to Windows window will appear. Type in your password and click OK. You are now working
from the remote desktop.

Log On to Windows

/

¥. Standard Edition

Copyright & 1885-2003 Micrasalt Corporation

User name: ImsmiT_.!’_l /7_

Password: I | F =

Log on ko IDCRDMZ j

K, Cancel | Shik Du:uwn...l Cpkions <<

IJ The first time you logon on to the server, you may see a "Manage Your Server" dialog box. Since it
is unlikely that you will be actively managing the archival server, you should check the box "Don't display
this page at logon" located at the bottom of the window. Then close the dialog box. If you would like to
see this page for whatever reason, it is available from the Start menu: Start > Administrative Tools 2>
Manage Your Server.

Open the EMCAP Administrative Console by double-clicking on the Admin Console icon on the desktop.

.

Admin Console

A Tour of the Interface

The main EMCAP Admin Console not only lists all active users, but it is where you will run the various
utilities offered by the application. Figures 1 and 2 show the data being tracked in the main window.
Note that each column (or field) represents a single piece of data about the account.
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& EMCAP Admin Console

Figure 1. EMCAP Admin Console

Domain:

Person Name:

Unit Name:

Contact E-mail:

Will Process:

Creation Date:

Represents an organized collection of users associated with one another. For

example, the users listed under the domain name “GRB and Friends” are all

affiliated with this specific agency.

The full name of the individual (or user) whose archival e-mail messages are

being imported, parsed, and preserved.

The unit within the agency in which the user belongs. Use forward slashes to

delimit name that makes up a hierarchy. For example:

Division/Section/Branch/Unit.

The main e-mail address of the user; his or her primary work e-mail address.

Checking this box means that this specific user account will be included in the

automated processing of e-mail messages to XML. Leave this box unchecked if

you don’t want it included in this process.

The date and time the user account was created.
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Eile  Edit Tools  Security
D omain: IGHB and Friends L] Statuz: ¥ Read?wiite ¥ Read Only  Closed W
Person Mame ‘ Unik M arne | Contact Email | WillProcess | Creation Date El:j
I egan Durden _ ] z Branch | megan. durdent
D avid kinor DCR AT david. minor@ncdor. gow i 4,/8/2008 2:.00 PM B
Jane Doe Your Uit Mame Goes Here megan. durdeni@ncmail. net W B/6/2008 4:08 PM 0
=i Druzcie Simpzon Archives druzcie. simpzoni@ncmail et ¥ 8/26/2008 11:47 M |0
Kelly Eubank. Gaovernment Records Branch kelly. eubank@ncder. goy = 4/1/200911:18 AM 137
Staci Meper Department of Cultural Resources david. minari@ncder. goy v 4/271/200911:05 4 |0
Many 5 amouelian DCR/Government Records Branch mary. zamoueliani@ncder. goy 2 472220091240 P |78
= Staci Meper2 Department of cultural Resources mary. zamoueliani@ncdor. goy 7 4/24/200911:03 4 |0
Staci Meper3 DCR staci. meyer@ncdor. goy 2 402720091022 abd | 23587
kany S amouslians DCR mary. zamoueliani@ncdor. goy v 442742009 1:30 P 0
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Ell:jrﬁ?ge Lazt Processed E;Zfeﬂsj:d Earliest Meszage Latest Meszage Address Status

2003 8:43 Pk 0 megan. durden Feadwrite
b4 5 3520091016 4 | B 84542008 726 PM 84542008 3:.07 PM darid. minor Readw/rite
b 1] I} jane doe Readw/rite
BT I} druzcie. simpson R eadiw/rite
4M 137 4142009 11:48 AM 137 12/4/2002 1253 4 | 10/2/2006 2:02 Ak kelly. eubank. Readw/rite
1Ak |0 42720091015 A (0 staci. meyer. temp Readwrite
IPM |78 ETH0091223PM |78 2AB/2003 1:39 AM 4202003 1057 Ak | mary. zamouelian Readw/rite
i |0 4272009 3:26 Abd I} shaci. mepers R eadiw/rite
raM o | 2357 427200311108 | 1514 942742007 2231 PM 42742008 3:34 AM shaci. meper3 Readw/rite
Phd n i rrvarn o arnenalian g Pazdirita

Figure 2. EMCAP Admin Console

Message Count: The total number of e-mail messages successfully processed (meaning parsed
and converted into XML).

Last Processed: The last date and time the processor was run or executed.
Processed Last Run: The number of messages parsed and converted to XML in the most recent job.
Earliest Message: The earliest date and time of creation of the message that has the earliest

creation date out of all the messages that have been processed and saved to the
main EMCAP message store.

Latest Message: The latest date and time of creation of the message that has the latest creation
date out of all the messages that have been processed and saved to the main
EMCAP message store.

Address: This is the local part of the e-mail address the client will use when connecting to
the archival mail server. This is in a firstname.lastname format.

Status: There are three options:

Read/Write: The account is fully operational. The user can add messages and
make basic changes to the account. This is the normal setting.

Read Only: The user may connect to the account and view its contents, but will
not be able to make any changes to the account. This includes adding new
messages. The user will not be able to tell if the account has been set to
ReadOnly until an operation is attempted at which time it will simply fail, usually
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with no error message being sent. Note that the processing engine temporarily
sets each account to ReadOnly during account processing.

Closed: The user’s account is no longer available via the mail server. Once an
account has been closed, it cannot be put back on line. This rarely will be used,
as the circumstances have to be unusual for the account to be closed.

@ You can select the width of each column by placing your mouse over the line separating two
columns, then clicking and dragging the line to the width you desire (note this will affect the column to
the left of the line). These column width settings will be saved in between sessions, so that when you
restart the application, the columns will have the same widths as they did the last time the application

was closed. In addition, you can reorder the data (i.e., alphabetically) in each column by clicking on the
column header.

Creating an Agency Domain

Before a user account can be created, a domain must be set up for his or her agency. This must be done
in close association with your IT department since the archival server must be configured to respond to
the corresponding DNS (Domain Name System) name.

From the main console window, review the domains listed in the drop-down box to determine if a
domain already exists.

& EMCAP Admin Console [_To[x]
File Edit Tools  Security

Status: ¥ Readfwite ™ ReadOnly W 0Off Line

| Uit M arne | Cantact Email | Status ‘ willProcess | Creation Date Erl:j:;aga | Last Processed
Mo durden E ent C
e E ST ey eubank Government Records Branch kelly.eubank. ncmail net Fieadwrit v 4/8/2008 7-53 P 1} 0
David Minor dawvid. minor DCR 41T david. rinorEncmail et Readwrite ~ 4/8/2008 &:00 PM 0 0
Jane Doe jane.dos “four Unit Mame Goes Here megan.durden@ncmail. net Readwrite Il B/6/2008 4:08 PM 1] 0

add [ Edt || Deete |[ TakeDitline | [ Close

User: DCROMZymdurden Last Wisited: 4/11./2008 12:38:26 PM
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If the domain is listed in the drop-down list, skip to the next section, Creating User Accounts beginning
on Page 14. If the domain for the user’s agency does not appear, from the toolbar, select File > Manage

Domains.

J[=] B3

& EMCAP Admin Console
File | Edit Tools  Security

Start Processor
) | Status ¥ Readfwite ¥ ReadOn [ 0ff Line
Wiew Processor Skatus

Message
Creation Date Count Last Processed

| wilProcess
ite: Iv]

allizon stivender@ncmail net | Readwrite

Contact Email | Status

Urit Narne

Reports ddress
an kel ail: ailnet |R

Select Current Domain

Jisan stivender
I

Manage Domains b
5/15/2008 12:58 PM

claire. ennis@ncmail net Readwite

e ehinis
Import PST

Export .PST

Exit

sdd || E@t  |[ Debte || TakeOiflie | [ oo

User DCRDMZ \mdurden Last Visited: 4/11/2008 12:38:26 PM

A Domains List window will appear that lists all of the current domains. Select Add button at the bottom
of the window to create a new domain for another agency, or alternatively from the toolbar select Edit

- Add Domain.

Fil=  Edit

| Creation Date | Active

| il Process | Domain Mame

| Agency Mame

Marme
GRE and Friends Gowvernment Rec ranch

oz emcap.hodor.goy 48/2008 7:55 PM
governor. emcap. hoder. goy 4/8/2008 7:56 P
sert.emcap.noder.gov 4872008 7-56 PM

Secretary of State Secretam of States Office

Citizen Affairz Community and Citizen Affairs

Emergency Management Emergency Management

I Hide offline domains

Edt || Delete || TakeDfine

Cloze | 1,.,
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The Register/Create Domain window lists all of the information needed to create a new domain.

[ E Register / Create Domain ﬂ E |

Domain Properties

MHame || Help |

Aagency Mame I

Diomain Mame I

will Process v Check to include thiz domain in e-mail to <ml conversion,
Active v Check ta make this domain available to IMAP clients.

Creation Date  [4/28/2009 17 15 A4

Mote

Save | | LCancel

The field descriptions are:

Name: This is essentially a nickname; it can be an abbreviated version of the agency
name, or it can just be the same.

Agency Name: The formal name of the agency that will use the EMCAP domain.
Domain Name: The structure in use for the pilot is: agencyabbreviation.emcap.ncdscr.gov.
For example, sos.emcap.ncdcr.gov

Will Process: This means the domain will be included in the automated processing of e-mail
to XML. Leave this box checked.

Active: This means that users in this domain will be able to use the EMCAP folder for
archival mail. Leave this box checked.

Note: The notes field is optional but is a place to include pertinent comments. For
example, make note of modifications or exceptions to this domain structure.

Once this information is updated, select the Save button at the bottom of the window. Select the Exit
button on the bottom of the Domain Lists window

EMCAP Server Administration
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@ The Help button located next to the Name field offers additional information about the role
domains have in the tool, and more detailed descriptions of the fields in this window.

Editing an Agency Domain

Editing an agency domain must be done in close association with your IT department since the archival
server must be configured to respond to the corresponding DNS name. To edit an agency domain, select
File > Manage Domains from the toolbar, or alternatively the Edit button at the bottom of the window.
A Domains List window will appear that lists all of the current domains. Highlight the domain you want
to edit, and then select the Edit button at the bottom of the window.

B Domains List

Fle Edi
Mame Aagency Mame Will Process | Domain Mame Creation Date Active
GRE and Friends Government Records Branch vl dor-sv3em.derdmz. local 4/8/20083 7:54 PM v
Secretary of State Secretary of States Office Il z08 emcap. hoder goy 4/8/2008 7:55 PM |7
Citizen Affairs Comrmunity and Citiz = aovernor. emcap. hodor. goy

[ Hide affline domains

| Dese | | Add || Edi

- 3

Delete || Take Diffine |

The Register/Create Domain window lists all of the information needed to edit the domain. When you
are finished editing, select the Save button at the bottom of the screen.

Deleting an Agency Domain

There may be circumstances where you will need to delete an existing agency domain. For example, you
may have created a test domain that is no longer needed or you created a domain in error. Deletion of
an agency domain means that all information associated with this domain will be permanently deleted
as if it never existed. Note that you cannot delete an agency domain that contains user accounts that
have processed e-mail messages.

To delete an agency domain, you will first need to delete all account records in the domain. Select File
- Manage Domains from the toolbar. A Domains List window will appear that lists all of the current

EMCAP Server Administration
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domains. Highlight the domain you want to delete, and then select the Delete button at the bottom of
the window. Verify the deletion by selecting OK.

@ Deleting an agency domain involves the deletion of user accounts, so extra care should be taken
when considering this option.

Taking an agency domain offline means that neither you nor the users associated with the domain will
have access to the records transferred or processed within the domain (i.e., the archive still exists, but is
no longer available via IMAP and no longer updatable). You must first close all account records in the
domain. Selecting this option from the Domain List window will remove the domain from the archival
server, however, the domain and all user accounts and associated data will be preserved.

@ Taking an agency domain offline severs all access to the messages unless your system is set up to
access those messages. As such, extra care should be taken when considering this operation. Do not do
this without first consulting with your IT staff.

Creating User Accounts

Once the domain exists, you can create individual or multiple user accounts for a specific domain in a
batch process.

Make sure you are in the correct domain by selecting the name from the Domain drop-down menu.
From the toolbar, select Tools—>Create Multiple Accounts.

" EMCAP Admin Console
File  Edit | Tools | Security

Opkions 3

Daomair: = == Readfwiite ¥ ReadOnly W 0O Line
Create Mulkiple Accounts ]

FPerzon Mame Address [Irit M amne Contact B

Megan Durden megat. durden Government Records: Branch megat.du
F.elly Eubank, kelly. eubank Government Records Branch kelly. eubs
D avid Minor david. rirar DCR AT david. mir
Jane Doe jane. doe “our Unit Mame Goes Here megan.du

A new Batch Account Creation window will appear (Figure 3). You have two options of creating accounts
from this window.

Option 1

EMCAP Server Administration
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If you have an extensive number of accounts to create, or a list compiled by someone else, you can

import the data as a .CSV (Comma Separated Values) formatted file.

Begin by selecting the Instructions button at the bottom of the window and following the directions.

:® Batch Account Creation

File  Edit  Options

Create Accounts for: GRB and Friends {dcr-sy3em.dcrdmz local)

Import File: || Load Browse. .

Parson MNarmes | Contact Email | Unit Marme j&ﬁddress

Then, browse to locate
the file and upload it.

First, follow instructions for
creating and saving a .csv
file

| Instructions ‘l ‘Qre’ateAc:u:Dunts | | Send hail HS&VEBEpDH‘ ‘ Close
&

Figure 3. Batch Creation

@ Pay particular attention to two items in the instructions. First, the Imports Account template was
created using Microsoft Excel. In order to successfully import the file, you must save it as .csv file when
you are finished with your edits. If you do not, an error message will appear and the file cannot be
imported. Second, if you decide to save the file onto your local computer, you must configure the
Remote Desktop Connection software to make your local hard drive available to this session. It is
recommended you save the file to the remote desktop versus your local drive.

Click Browse to identify the file and then Load to import it.

EMCAP Server Administration
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Option 2

If you are only adding one
or two users, names can

be entered line by line.
Starting at the text box
next to the asterisk (*),
enter the user’s name
(e.g., “John Doe”), the
user’s normal work e-mail
address, and the unit
name. The address (the
EMCAP address) will be
automatically created
based on the contact e-
mail address. If the
contact e-mail address
name is different from the
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-# Batch Account Creation M= E
File  Edit  Options
Create Accounts for: GRB and Friends {dcr-sy3em.dcrdmz local)
Import File: | | Load | ‘ Browse... |
Persan MName /| Contact Emnail Unit Mame Address

-

John Doe

john.doe@ncmail.net

Human Resources

john.doe

4
F i
| Instructions |G Create Accounts D GSend kil DSa\ze Fepaort | | Close | :
: e = |

address name (i.e., the contact e-mail is johnd@agency.gov and the address name is john.doe), then
manually type in the address. Use tab to move between the fields. Note that the first three fields cannot

be left blank.

After adding user information using Option 1 or Option 2, select Create Accounts at the bottom of the

window. If the accounts are successfully created, a Report window will appear validating the number of

rows (accounts) added. Each successful row will turn blue. If there are problems with the creation of the

accounts, an error message will pop-up and any problem rows will be identified in pale yellow.

After all the accounts have been created, select the Send Mail button at the bottom of the window to

send an automated introductory e-mail message to notify each new user of the account creation and to

provide steps to change the EMCAP password.

A Send Welcome Message window will appear (Figure 4).

EMCAP Server Administration
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"EMCAP Admin Console

Ei i‘-‘.‘tch ccuuntl:retiun _ O] =]
Dc File  Edit  Options
: Create Accounts for: GRB and Friends ({dcr-s¥3em.dcrdmz. local) {
— Import File: | | Load ‘ | Browse... | —
: Contact Email Lnit Mame | Address | Error Message :
_|*» |johndoe@ncmail net Hurman Resources =
i
Send Welcome Message
This will send an e-mail message to each of the accounts just created.

Instructions

‘ Cret

T Ei

I

Only those accounts that are marked as completed will be included.
The e-mail message will be sent to the persan's contact e-mail address.

Form Letter: |GHB and friends j Edit Form Lefter | Delete Form Letter |
Add Form Letter |
UserWeh Site: Ihttps:a’a"ncalchives.dcr.state.nc.usx’emcad =1 |
Preview Sample Message | Configure Mail Settings |
send Messages | Close

Figure 4. Send Message window

Select the appropriate form letter from the Form Letter drop down list, and either edit, add or delete

the form letter.

Type the web address for the Welcome page to the EMCAP Account Status tool into the User Web Site
field. This address is https://ncarchives.dcr.state.nc.us/emcap.

@ It is important to type in the User Web Site as it will give each user individual access to the
Welcome page of the EMCAP Account Status tool. Here, the user is responsible for creating an Archival
account password and then resetting the temporary password in their e-mail client (Outlook) to reflect
this new password. This is necessary to allow the user access to the archival server. The process for this
is outlined in the User Guidelines.

To ensure that the administrator is the individual sending the e-mail, select the Configure Mail Settings.
The Send Mail Settings window will appear.

EMCAP Server Administration
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From this window, you £} Send Mail Settings

can verify that the Send Mail Settings ]
sender’s (or

L. , A Enter the name or IF address of the sernser to which SMTF traffic will be routed.
administrator’s) address is

correct and change the SMTF Server Address: ismtp.mail.nc.gov

address if it not correct. SMTP PortNumbsr: 25 |
Note that once you ]
change the sender’s [fthe SMTF serverrequires a user account for authentication, enter it here.

Otherwise leawve it blank. (Mote this is often an e-mail address.)

address, the Recipient
Account Marme: |

Address field will |

Account Passwaord: |

automatically be

populated with the same The person receiving the mail will see the message as coming from this account,

e-mail address. You can All non-delivery notices will show up in this account's inbaox

select the Send Test Sender's Address: |jane.doe@ncdcr.gov

Message to yourself (as
the recipient) ensure that ﬂl ﬂl

the e-mail is being sent.

Once this is confirmed, il ivisae i
the window can be Fecipient address: (Ercdor.goy
closed. send Test Message

Back on the Batch Creation window, you can also preview message being sent by selecting the Preview
Sample Message button.

If everything is accurate, click the Send Message button at the bottom of window. A confirmation
window (Sent Count) will appear, verifying the number of messages sent. Click OK and then select the
Close button on the Send Welcome Message window and the Batch Account Creation window.

The new user(s) will receive a welcome e-mail message (Figure 5). In addition, the new user record will
be added to the main Admin Console page.
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To:

Doe, John
el
Subject: Mew Archival Account
Dear John Doe N

Welcome! Thank you for participating in the EMCAP pilot.

A new e-mail account has been created on the Archival E-mail Collection and Preservation server (EMCAP) for
your use. :
ccount which allows user to

The account address is john.doe@dcr-sviem.dcrdmz.local €————————— drop archllv_al llﬂ ssages into
arcnival senver.

Someone from your support staff will be visiting you scon to add this account to your e-mail client.

For a tutorial on how to use this service, please wisit this web site: )
http://www.ah.dcr.state.nc.us/records/emailpreservation/training.htm Link to EMCAR

/ Welcome Page
Before this account can be used it must be activated by clicking here

https://ncarchives.dcr.state.nc.us/emcap/Activate.aspxlaccountid=56fksess=WswiPp31XpAisk/su/CGEg
You will be able to choose a password at that time.

Email address of

This account has been registered with the following information: S

Account Ouwner: JohnDoe
Contact e-mail address: jane.doe@ncder.gov Unit Name: Department of cultural Resources

If any of these items are incorrect please update them by visiting the following web site:
https://ncarchives.dcr.state.nc.us/emcap

Figure 5. Welcome e-mail message

Editing User Accounts

Additional information may need to be added to the user account. Highlight the user account, and then
select Edit - Edit Account from the toolbar, or alternatively the Edit button at the bottom of the screen
(Figure 6).
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& EMCAP Admin Console [ _ [O] x|
File | Edit | Tools  Security
Mew Account Ale+a | v o w
Darn S — ——jtatus v Read/wiite v Fead Onl Closed Iv
I" Edit Accaunt AlE+HE SR ey S5
Delete Account Ale+D i B Account Properties - '_ast Frocessed E;Z??;ﬁf:d E arliest
[ | Close Account Ale+C i 7 ; £ ;
- Account Properties Domain: GRB and Friends {EABAIRM (D
Dravid Minor DCR A15/2003 10164 |B 8/5/200:
Jareibns MG Account Address: I @dor-svdem.derdmz, v
Druscie Simpzon Archi = o
Person's Mame: I.Jnhn Doe
Kelly Eubank. Gove, /142009 11:48 AM 137 12/4/200
Staci Meyer Depa LT [Human Fiesources J2742009 1015 AW [ D
Mary Samauelian DCR. Contact Email Iiohn.doe@ncmail.net SETAA031223PM |78 2MEB/20
Staci Meyer2 Depal R nUr R Readwiita = 7 will Process e 272009 926 Ad o
Staci Meyerd DCR o S27A200511:1048M (1514 9427200
otes:
Mary S amauelian DCR Add pertinent information here

b |JohnDoe um: including title, dates of employment,

| Save | | Lancel | Help | Change Password

Account Information

Account Created: lm Last procceszed on: IW
Total Messages Archived: ID— Meszages Archived Last Bur: ln.-"c'._
Ealiest Message: I— Online Disk Space: ,U—
Latest Message: l— Offline Disk Space: ID—

| | édd | I Edit || D Store Folder: IE:\E mcapStoreGREandFrisndshjohn dos

Uszer: DERDMZNmsamouelian © Last Visited: 4/28/2003 10:08:32 AM

Figure 6. Edit user account

Make necessary changes, including the user’s title, employment dates, or other pertinent information
and select the Save button.

[Note: the function to close a user account currently does not work].

There may be circumstances where you will need to either delete or close an existing user account. You
can delete an account only if 1) there are no messages associated with this account; 2) there are
unprocessed e-mail messages associated with the account (meaning e-mail messages are sitting on the
archival server, but have not yet been processed). You can verify this by looking at the Message Count
field in the Admin Console. If the number is greater than zero, this means you have processed some
messages. If you have processed messages associated with an account, you will need to close the
account instead of deleting it. When you close an account, all its associated messages are preserved on
the archival server, however, it they are no longer accessible via the IMAP connection.

To delete a user account, highlight the account you want to delete and either select Edit > Delete
Account from the toolbar or alternatively the Delete button at the bottom of the screen. If there are
messages on the mail server for this account that have not been processed a Messages still on mail
server window will appear indicating that these associated messages will not be processed until the
account is re-registered (Figure 7).
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Messages still on mail server

re-reqgistered,

\::) This account has 1 messages on the mail server, These messages will not be be deleted, but they will not be processed until this account is
-
Are you sure you want to remove this account?

Figure 7. Messages still on server

If you are certain you want to remove this account from the mail server, select Yes.

@ Re-registering an account currently does not work. Do not delete an account that has unprocessed
messages associated with it.

To close a user account, highlight the account you want to close and then either select Edit = Close
Account from the toolbar or alternatively the Close Account button at the bottom of the screen. A Close
Account? window will appear confirming whether you want to close the account.

Close Account? [ %}

Are wou sure wou want ko close this account?
Once an account has been closed (i.e., the messages have been removed from the hiMailServer, and the hMailServer's account deleted, the messages
stored in EMCARP cannok be used ko reload hmail,

(Recreating the hMailServer account and reloading From the EMCAP stare is possible, .,
Howewer the software required ko perform this task has not wet been written. )

Verify that you want to close the account by selecting Yes.

Closing an account currently does not work.
.PST Files

When e-mail messages are removed from an individual’s computer hard drive, the files are saved as

Microsoft Outlook data (.pst) files. These files are generally transferred to the repository via a digital

storage medium, such as a DVD. In order for these types of files to be parsed and converted to XML,

they must first be identified and then prepared to be imported into the archival server via the Admin
Console.

Identifying and Preparing .pst Files for Import

Identify all .pst files and messages on transferred digital media by opening the storage medium in
Windows Explorer.

Copy the .pst files from the digital storage media (i.e., DVD) to a folder on your local hard drive.
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@ By default, Outlook data files are saved at: drive: \Documents and Settings\user\Local
Settings\Application Data\Microsoft\Outlook. It is recommended that you change this path to

something simpler (such as C:\Outlook PST) to make locating these files easier.

As the names of the .pst files may not accurately reflect the contents of the files (i.e., a file may be

named “Outlook2.pst”), it is recommended that the files be renamed. This can be done from Windows
Explorer by right-clicking on the file, selecting Rename, and typing in the new name.

3 Uiilogls uat Fils

BGIE)

Rl Edit  Wiew

@Back L > ? j:] Search

Address £ C:\outlook pst Files

Faworites  Tools  Help

[L—“ » Folders

Folders
@ Desktop
# L,J_] My Documents
= -j Iy Computer
& ﬂ, 314 Floppy (A
[ G OckZO05 (C:)
F () arcgis
F [ BulkRenameltility
(5 del
# [25) Documents and Settings
F () DRIYERS
# ([7) i386
# [7) Kpcms
# |5) MetaExtractor
F [ MsoCache
F ) MvIDIA
22 outlock pst Files
# [Z3) Program Files
F [ Pythonzs
# [7) scanwizard 5 w6.11
5y wos
F (5 WINDOWS
i DVDJCD-Rw Drive (D:)
== Removable Disk (E:)
G LaCie (F:)
% mamoueliand on 'dor_vs1' (H:)
% Dahg on 'dor_ws1' (L)
S inetpubd on MewderwbI01d' (W

New folder created to
temporarily store _pst
files.

BHEE®E

=

v |§}I Faolder Sync

x Mame -«
L:.J LE]Far_David.pst

| ;}r

iz

2,240k

14,153 k
67,473k
279,761 k

Send To N 269,341 k

|- 642,833 k
Cuk

Copy

7-Zip 3
Open With »

Create Shaortcut

Delete

Propetties

<]

olll,

=

Prior to importing the .pst files to the archival server via the Admin Console, you should open all files to

assess its contents. To view the contents of.pst files, you will need to open them in the Microsoft

Outlook client.
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Outlook only allows you to open one file at

a time, you will need to repeat t
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A new folder containing the e-m
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important to note that the names of these

folders may not be identical to t
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local drive, as Microsoft Outlook gives
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on the  File | Edit  View Go
utlook Mew
Qpen

osoft Close All Ttems

. Folder
his step as

Import and Export...
ail Archive...
pear in the _
. Print...
IS

he original Work Offline

d to your Exit

Data File Management...

Cached Exchange Mode

Tools
k
L4 Other User's Folder...
Calendar...
[ Outlook Data File...

[
Ml

Ctrl+P

]

users the option of changing the folder name. For example, a .pst file may be named “Outlook2.pst”, but

when you open it in Microsoft Outlook, the folder name containing the messages may be named “Do

Not Open this File!”

It is recommended to rename the folders to match the names of the .pst files.

In Microsoft Outlook, highlight the folder to be renamed. Right click and select Properties for “folder

name”.

=

=l &= Personal Folders MES 3

= [ Business Related E-Mail

|| Digital Preservation '-_"ldmz local

3 EMCAP [30]

Highlight folder

1 GeoMapp [13]
# [ Policies and Guidelines
fa] Deleted fems
= [ Personal
3 Website Updates

5 open

Open in New Window
ale

i

Aename “Persanal Falders M
Hew Folder...

Add to Favorite Folders
Process All Marked Headers
Process Marked Headers

Open Other Folder

X Close "Personal Folders MES

ﬁr" Properties for "Persanal Folders MES®...

A Properties window will appear (Figure 8).
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' EETsomal ol erEan S O PENIEs J Hﬁ

| General | Home Page |

g Personal Folders MES

Type: Folder conkaining Mail and Post Ikems
Location: Microsoft OFfice Outlook,
Descripkion:

(%) Show number of unread items
{1 show kotal number of items

‘When posting ko this Folder, use; | IPM.Post

Automatically generate Microsoft Exchange views
[ pisplay reminders and tasks From this Falder in the To-Do Bar

Folder Size...

[ Ilpgrade to Color Categories. . ]

Figure 8. Folder properties window

Click the Advanced button. A Personal Folders window will appear.

PersonalEolders : 3 In the Name field, type in the new name of the
e o » folder and select OK and this window will close.
General of folder
Marne: Personal Folders MES / To close out remaining window, click OK.

Filenarne: Y uklook pst FilesiPersonal Folders MES, psk Repeat this process for all folders

Forrmat: Personal Folders File
Changes the password used to access
Change Password. . the personal Falder File
Reduces the size of your personal
COMPaCEMNAW | folder File e

Cornrmenkt

[ 0] 4 ] Cancel
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Open each extracted folder to identify all e-mail messages. Possible messages could reside in the Inbox,
Sent Items, Draft, etc.

@ By default, Microsoft Outlook does not display the number of e-mail messages residing in a
particular folder. To view these numbers, you can highlight the folder where messages are stored, and
then right click on the folder. Select Properties. A folder window will appear. On the General tab, click
the button “Show total number of items” and then hit Apply = OK. The number of items in the folder
will be displayed in green. This number can be compared to the number of messages imported and
parsed. Note this number (i.e., write it down!) as it will be useful to compare with when the files are
imported and then processed in the Admin Console.

@ If there are no e-mail messages in any of the folders, you may only have other backed up items,
such as calendar items or contacts. You can verify this by selecting the different subfolders to determine
if there is any information. If there are no e-mail messages, both the data file in Microsoft Outlook and
the .pst file on your local drive need to be deleted.

Highlight the folder to be deleted. From the toolbar, select File > Data File Management.

An Account Settings window will appear.

Data Files
Outlook Data Files

E-mail [rata Files R55 Feeds | SharsPaint Lists | Internet Calendars | Published Calendars || Address Books |

g Add... o Settings... @ Set as Default | 3¢ Remove | Open Folder...

Mame Filename Camment
Far David Far_David,pst in C:outloak pst Files

Mailbo: - Samouelian, M., outlook.ost in CDocuments and Sethingsimsamouelianilocal .., Defaul
mary, samoueliani@dcr-s...  outlmary, samouelian@dcr-sv3em, decrdmez Jocal-00000003. pst in ...

Personal Folders MES Personal Folders MES. pst in C:\Outlook pst Files

staci, meyer@der-sy3em...  outlstaci.meyver@der-sv3em, derdmz . local-0000000b. pst in 2D, .,
staci, meyerZ@dcr-sv3e, ., outlstach.mever2@dcr-sv3em, dordmz, local-00000010.pst in i

Skaci_Mever_Masker Staci_Mewer _Master,pst in C:iOutlook pst Files Data file to
Stacy_Mever_1 Staci_Mewer_1.pst in Z:0utlook pst Files — he removed
Stacy_Mever_Z Staci_Mewer _Z.pst in Z:Outlook pst Files
Stacy_Mever_3 Staci_Mewver 3, pst in i Outlook psk Files

Select a data file in the list, then click Settings for more details or click Open Folder to display the Tell Me Mare
folder that contains the data file, To move ar copy these files, wou must first shut down Outlook.

Close
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Highlight the data file you want to remove, and then select the Remove button.

A confirmation window will appear for removal, click Yes. Select Close button.

@ You may need to close out of the Microsoft Outlook client to remove the data file from your local
drive. It takes a minute or two for the system to catch up and remove the temporary data file (this has a
.tmp extension). You cannot delete the .pst data file without its corresponding .tmp file being closed.

The Admin Console is designed to import only one (1) .pst file. This means that if you import one .pst for
a user account and then attempt to import a second .pst file into the same user account, the first .pst
file will be overwritten. As a result, multiple .pst files for the same account must be merged (or copied)
into one master .pst file before being imported and subsequently processed in the Admin Console.

Open the Microsoft Outlook e-mail client.

From the toolbar, select File > New - Outlook Data File.

 File | Edit View Go Tools

[ New ¥ |30 Mail Message Ctri=N
Open L4 "_":,J Post in This Folder Ctrl=Shift+5
Closg All Items [ Folder. Ctrl=Shift<E

Bl save ss.. Ll Search Folder... Ctrl=5hift+P
Save Attachments J Mavigation Pane Shorteut..,
Eolder ¥ | Appointment Ctrl=Shift=4
Data File Management... Jj Peeting Regquest Ctrl=5hift= Q)
Import and Export... 85 Contact Ctrl=5hift+C
Archive... ﬁ Distribution List Ctrl=5hift+L
Page Setup b | & Task Ctrl=Shift=K

i Print Preview il Task Request Ctrl=5hift=U

HSQ Erint... Ckrl+P jﬂ Journal Entry Ctrl=5hift+)
Cached Exchange Mode  » | | Note Ctrl+Shift=N
Waork Offline @ Internet Fax Ctrl+Shift+X
Exit E Choose Form...

E}  ChooseInfoPath Form... Ctrl=Shift=T
Cutlook Data File... h .
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A New Outlook Data File window will appear.

Tvpes of storage:

Office Qutlook Personal Folders File (. psk)
Cutlook 97-2002 Personal Folders File {.pst)

Descripkion

Provides more storage capacity for items and Folders,
Supports mulkilingual Unicode data. Mok compatible with
Oublaok 97, 98, 2000, and 2002,

I Ok ] [ Cancel

“Office Outlook Personal Folders File (.pst)” will be highlighted. Unless you are certain that the outlook
data files predate 2002, you can keep this selection highlighted and then select the OK button.

Browse and select a location for the new .pst file — this should be in the same location on your local
drive where the other .pst files are saved. Type in the new File Name in the field at the bottom of the
screen (for example, Firstname_Lastname_Master), and then click OK.

A Create Microsoft Personal Folders window will appear.

Files i\ Dutlook pst Files) Test. pst
Mame:  |Personal Folders

Farmat: | Personal Falders File
THeESE Can be
Passwiord

o left blank
Password;

Merify Passwaord;

[ ]5ave this password in vour password list

I Ok ]I Cancel ]

Type in the name of the folder you are creating in the Name: field (it is recommended you give the
folder the same name as the newly created .pst file). The Password option is available for those wanting
to protect their personal Outlook data by creating a password to prevent viewing by others. This should
be left blank. Click OK.

The new folder you just created will appear in the Outlook Mail tree on the left of the screen.
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Under the master folder, create subfolders for each .pst file you plan moving into it.

Highlight the master folder. From the toolbar, select File > New Folder. A Create New Folder window
will appear.

Type in the name of the subfolder (the same as the .pst folder you renamed as outlined in the previous
section). Select the location of the subfolder by highlighting the master folder. Click OK.

2 £ Jane_Doe_Master
@ Deleted Items

@ g Jane_Doe 1 Subfolders -
5 o3 Jane_Doe 2
# [J Jane Doe 3

L@ Search Folders
# & Jane Doe 1
3 & Jane Doe 2 Criginal data
Bl e j % file
H 5 Jane Doe 3 LS

To copy the .pst files into the master .pst file, highlight the folder or files you would like to copy.
Right click and select Copy “folder name”.

= & Jane Doe 2

fa] Deleted Hems Folder to be

(1 Drafts (,/ copied

__iInbox; [570¢]

L g Junk E-mail [270] I A = @ Joani
[ Library Group 4

7 Sent Items [345] = Qpen

A Trash [14] Open in New Window

L@ search Faolders

Yerifies what

is being -

copied

[ MNew Folder...

Add to Favorite Folders

Mark All as Rgad
Process All Marked Headers

Process Marked Headers

5F Properties
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A Copy Folder window will appear. Select the location where you would like the folder copied and select
OK.

?t-E o Fuld=y JQ*
« Copy the selected folder to the Folder:
I == lane_Coe_Master 'Lu'
| {a] Deleted Ttems
i # 3 Jane_Doe_1
| & [JJane_Doe_2
| # [d|ane Doe 3 Mew...,
=3 |ane_Doe 1
| = & Jane_Doe 2 Copy Inbox of
| '-'En‘ Deleted Items Jang_ [Ooe 2
i [ Drafts orignal to
i L Inbox [3705] | Jane_Dog 2
| '.@ Junk E-mail [270] subfolder under
! [ Library Group &8 master fie
' [ Sent Items [345] E
Forg

Repeat this process for all folders until all the folders have been copied into the master folder. You are
now ready to import the master .pst file.

@ Microsoft Outlook will only allow you to copy one folder at a time. For a quick check on whether
the .pst files were copied into the master .pst file, you can go to Windows Explorer and locate the
master .pst file. As .pst files are copied into it, the size of the file will increase.

@ Microsoft Outlook is a bit quirky when dealing with opened data files. Prior to importing the .pst
file via the Admin Console, you need to make sure that all evidence of the data file is removed from the
e-mail client. Following the directions on page 24, remove all the data files opened in your e-mail client.

Creating a User Account

Prior to importing the .pst file, you need to create a new user account in the Admin Console in order to
associate the .pst file with a name/account.

Following the directions beginning on Page 5, log into the Admin Console.

Make sure you are in the correct domain by selecting the name from the Domain drop-down menu.
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Click the Add button at the bottom of the screen, or alternatively from the toolbar, select Edit > New
Account. An Accounts Properties window will open that lists all of the information needed for the new
user account (Figure 9).

B EMCAP Admin Console

File | Edit | Tools  Security
 HewAccount  AlEA g
Dom e— T e IV Readfwiite ¥ ReadOnly  Closed IV
ot Account Properties —
Delete Account Ale+0 a st Proceszed
Close Account Al | Account Properties Domain: GRB and Friends
D avid Minor DCR /I S A R _ 5/2009 B:16 AM
Aocount Address: [jane.smith @der-sv3em.derdmzlocal ] F—
Jane Doe Your Un =
Diruzcie Simpson Archives Person’s Hame: IJane Smith
Felly Evbark, Governr Unit Marme: |Department of Cultural Resources F2009 11:48 A
] Eepisity) Contact Ermail: |iane.smith@ncdcr. gov M
tary S amouelian DCR /G i 5 i 7 v 772003 4:23 &AM
coount Status: eadrite > v il P W Ach T
Staci Meyer2 Depattr Vs S 7/2009 5:26 AM
Staci Meyerd DCR Motes: w/as Acting Director of the Department of Cultural Resources from 2001-2008 during the E/2009 11:10 PM
- Governor Jones administration,| _—
hary 5 amouslianz DCA \ Pertinent datails about
david test individual's tenure. 872003 8:24 &AM

Save | | LCancel | Help |

Account Information

Account Created: Im Last proccessed on: IW
Total Messages Archived: ID— Meszages Archived Last Run: In.-’a—
E aliest Meszage: I— Online Digk Space; ID—
L atest Mezzage: I— Offline Dizk 5 pace: W

Store Folder: |E: SEmcapStoreiERBandFnends

|\ bad || Eée || Do

TT T —;

Uszer DCRDMZ mzamauelian  Last Visited: 4/29/2009 12:2%:11 Phd

Figure 9. New account creation

The field descriptions are:

Account Address: Enter the portion of the EMCAP e-mail address that appears before the “@”
symbol. This should be in firstname.lastname format.

Person’s Name: The full name of the person.

Unit Name: The name of the agency to which this person belonged.

Contact Email: This is the name of the account that received the mail messages that are being
imported.

Account Status: Keep to the default Read/Write. This means that the account is fully
operational.
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Notes: The notes field is optional but is a place to include pertinent information,
particularly the individual’s former title and dates of employment. Include any
information that will make this individual easily identifiable.

Once all of this information has been entered, click Save.

A Set Password window will appear.

i & Set Password I

Set Password

Account: fred johnson@mail testdomain.com

Fassword: ||

Confirm Password: |

Ok | Cancel auggest

Click the Suggest button and a Suggested Password window will appear with a suggested password.

Write this password down as you may need to have this password available at a later time. Click Yes to
confirm. The window will automatically close and the new user will appear on the main console page.

If you need to create additional user accounts, continue the process for the remaining accounts.

Importing .PST Files

Before the .pst file can be imported via the Admin Console, the .pst file must be copied from your local
drive to the C: / (or local) drive of the archival server.

@ Your Network Administrator can set up direct access to the .pst file sitting on your local drive from
the remote desktop so that the file does not have to be copied over the network.

Microsoft Outlook 2007 must be configured on the server so that it can support the Import.PST function.

This can be accomplished by either starting Microsoft Outlook from the Start Menu on the remote
desktop, or by running the Import.PST function from the EMCAP Administrative Console.
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Starting Microsoft Outlook from the Start Menu

From the remote desktop, select Start 2> Microsoft Office Outlook. The Outlook 2007 Startup Screen

will appear:

1.

Press next to go to the next screen.

Answer No to the question: "You can configure Outlook to connect to Internet E-mail,
Microsoft Exchange, or other E-mail server. Would you like to configure an E-mail
account?”

Then press next.
Check the box "Continue with no e-mail support." And press Finish.
Enter your full name and your initials. Press OK.

Answer the question about RSS feeds. Since you will probably not be using RSS feeds, press
No.

Since you probably will not be doing a whole lot of searching, answer “No” to the question
"Do you want to go to Microsoft Download Center to download this component now [i.e.
the Instant Search feature]?"

It is recommended leaving the privacy options as is: “Only Search Microsoft Office Online
for Help content when I'm connected to the Internet." Leave the other two options
unchecked.

Running Import.PST for the First Time

The first time that the Import.PST function is used, Microsoft Windows will launch the Outlook 2007
Startup screen.

1.

Press next to go to the next screen.

Answer No to the question: "You can configure Outlook to connect to Internet E-mail,
Microsoft Exchange, or other E-mail server. Would you like to configure an E-mail
account?”

Then press next.

Check the box "Continue with no e-mail support." And press Finish.

Prior to importing the .pst file, verify that no one else is using the account. You can then highlight the

user account whose .pst file you want to import.
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To launch the import utility, select File 2 Import.PST from the toolbar. The Import Outlook PST File
window will appear.

Import Dutook PST File Click the Browse button

to locate the .pst file to
Import Outlook PST file L be imported by either
Source: - highlighting the file and

PST File: [EOutiaok pst Files\Persanal Folders MES pst clicking Open or double

1 Browse |

clicking on the file.

For Destination, make

Destination: " sure that the Selected
* Selected account Account button is
2 jane.doef@dcr-sv3em.dcrdmz local selected.

If you do not want the
messages automatically

 Mew Account processed after they

3 have been imported,
Options: uncheck the “Run XML
™ Bun #hL Converer After lrmport: Converter After Import”

rC o L i
oy Lo W ewrer checkbox.

Select the Import

4 Impor | Cancel |
" button.

A Converter Will Not Run window will appear verifying that the converter will not be run immediately
after import. Select OK.

Converter Will Not Run

L]
9 11) The corverter will NOT be run immediately after impork,
=

An Import PST Status window will appear. It keeps a running count of the total messages found and total
messages or imported (see Figure 10). Note that this window will NOT appear after selecting the Import
button if the option to run the XML converter after import box is checked.
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mportpsTstatus M|

Importing Qutlook PST file

Total Messages: BE2

Processed: 310

Figure 10. Import PST Status

If the .pst file was successfully imported, a Success window will appear confirming this.

There may be circumstances where the .pst file you previously imported and process for a user account
needs to be refreshed (or rebuilt). If this is the case, it is important to understand that the current
archived email messages sitting on the archival server (that have been imported, parsed and converted
to XML) will be overwritten. As such, use caution when doing using this feature.

Highlight the user account whose .pst file you want to import.

From the toolbar, select File > Import .PST. The Import Outlook PST File window will appear

Click the Browse button to locate the .pst file to be imported by either highlighting the file and clicking
Open or double clicking on the file.

For Destination, make sure that the Selected Account button is selected. The Rebuild checkbox will be
checked and grayed out — it cannot be edited. This indicates that you are rebuilding the import.

The “Run XML Converter After Import” box will automatically be checked. If you do not want to
automatically run the XML converter after the import, uncheck this box.

Select Import button. A Rebuild window will appear warning that all messages in the XML store will be
deleted. Select the Yes button to confirm (Figure 11).

Selecting No will give you the opportunity to back out of the target account that contains any messages.
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Rebuild

::/ ‘\Warning! Possible data loss.
o)

Al messages in the %ML store will be deleted, Only the messsages imported From Ehis Qutlook Data File will be saved inko XML,
Are wou sure you want ko conkinue.

Yes

Figure 11. Rebuild window

The Import PST Status window will appear. If the .pst file was successfully imported and processed, a
Success window will appear confirming this and a new number of messages processed will appear in the
Message Count and Last Processed Run fields for the user account.

There may be a situation where the .pst file(s) you want to import belong to a former EMCAP user (i.e.,
the former EMCAP user is no longer employed and additional archival e-mail messages are discovered in
his/her e-mail client). If this user account still exists, you will be able to copy (versus importing via the
Import utility) the .pst file(s) directly into the user’s archival e-mail account.

Your IT administrator will first need to configure your e-mail client so that it will point to the user’s
archival e-mail account. The user’s archival account will appear as another account folder in your e-mail
client.

With main Mailbox highlighted, on the toolbar select File > Open - Outlook Data File, and browse to
the location of.pst file to be opened. As Microsoft Outlook only allows you to open one file at a time,
you will need to repeat this step as necessary.

A new folder containing the e-mail messages and post items will appear in the tree on the left of the
screen.

Using the method described on pages 27 and 28; copy the sub folders into the user account. These
archival e-mail messages are now available for processing.

After you are finished with the user’s archival account, it needs to be deleted from Microsoft Outlook.
From the toolbar, select File > Data File Management.

The Account Settings window will appear (Figure 12). Select the E-Mail tab.

Highlight the user account you want to remove, and then select the Remove button.
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E-mail Accounts
You can add or remaove an account, You can seleck an account and change iks settings,

1
Emal ||Data Files | RSS Feeds | SharePoint Lists | Internet Calendars | Published Calendars | Address Books |
. 3
i Mew... 3 Repair... 5 Change.., ©F Sebas Defa 7 Remove |1
[lame Tuwne
jane doe@dcr-sviem. derdmz local Exchange {send From this account I:u'w;.-' default)
2

Figure 12. Account Settings window

Another Accounts Settings window will appear, asking if you want to remove the account. Select Yes.
The account will be removed. Close the Accounts Settings window by clicking the Close button at the
bottom.

Processing Archival E-mail Messages

Once the user has copied or moved his/her archival e-mails into the archival IMAP folder or after the
.pst file has been imported into the archival server via the Admin Console, the administrator can process
the messages. Via the Start Processor tool, the application collects the messages off of the archival
server, and parses and converts them into XML. Attachments will be extracted and saved to a Windows
file system as regular Windows files.

@ Running this process will remove all messages from the user’s active IMAP store. These messages
will remain in the archival store for the long-term.

Prior to processing messages, verify that no one else is using the account. Then on the main page of the
Admin Console, highlight the user whose e-mail messages you would like to process (Figure 13).

You can begin the processor in several ways:

Highlight the user account whose messages you want to process. At the bottom of the screen, select the
Start Processor button.
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&' EMCAP Admin Console
Ele Edit Tools
Highlight User
1 = TR IF rergency Management vM Readfwite ¥ ReadOnlp  Closed ¥

e
Person Mame Unit Mame ‘ Contact Email ‘ WillProcess

Emergency bgmt m.org 1]

r | o e : .G v | i |0

Meszage

e Last Prc

LCreation Date

add || Edit || Delete || Close Account | |

User DCRDMZ msamouslian  Last Visited: 4/30/2003 1:45:09 PM ©

| rrm—y

Figure 13. Start Processor

A Process Accounts window will appear (Figure 14). Select the account or accounts you wish to process.
The Rebuild check box should remain unchecked.

To track and view the process progress, make sure that Start Log Viewer is checked. Select the Start
Processing button.

Alternatively, you can open the processor from the toolbar, by selecting File > Start Processor OR from
the toolbar select File > Verify Accounts, and click the Start Processing button.
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Ly

B Process Accounts

Process Accounts

@ Selected account | [ Rebuild
jane doe{@sert. emcap.ncdcr.gov

= All accounts within the selected daomain.

Emergency Management {sert. emcap.ncdcr.gov)

T All accounts in all damains

¥V Start Log Viewer Start Frocessing Cancel

A Log4Net View window will appear showing a running total of the messages being processed. You will
also notice a DOS window running in the background.

% Program Files \DCREmcap'EmcapCore.exe

RBunning,. type "exit" to stop. The stop flag is checked every 20BH messages.

If the processing tool is successful, the Log Viewer will cease to add records, and the DOS window
running in the background will close automatically. The Log4Net View window can be closed.

The “Message Count” field will be populated with a number reflecting the number of messages
processed (Figure 15). Note that this number is cumulative, meaning as additional processing jobs are
run this number will increase reflecting the total number of messages processed. This will not be true for
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a user account for which the messages were imported via a .pst file. As the system is set up to accept
only one .pst file, the Message Count and Processed Last Run numbers will be identical.

- __________________________________________________________________________________________________________________________|]
E"EMCAP Admin Console

File  Edit Tools

T ET R [Citizern Affaire] Statuz ¥ ReadAwite ™ ReadOnly  Clased M
: : Message Praceszed ;
Person Name WilProcess | Creation Date Count Last Processed e Earliest Message Latest Message
b ¥ 5452008101460 |0 2/9/2009902FM |0
| | | % |sascomsizeseM o | ln | | |
[|  eochivestioviice | | |emicoceiiooam 38071 |218/2009357PM 1075 |1/23/200310:33AM | 9/5/203312:32PM

Figure 15. Processed messages

Additional fields in the Admin Console will be updated. The Last Processed date will be updated with the
most recent run, the Processed Last Run will show how many records were processed in the most
current run, and the Earliest and Latest Message fields will be updated if this information changed as a
result of the most recent process job.

You also have the option of opening the log associated with your specific processing run. These logs are
saved as text files and within each file is a complete inventory of each step performed when the
processor was run, including the account processed, the number of messages found and the number of
messages parsed and converted to XML.

To view the logs, from the toolbar, select File > Open Log File Folder.

These text files are organized by the date and time the job was run (with most recent at the bottom of
the list). The naming convention is YYYYMMDDT(for “time”)HHMM (note: hour and minutes are in
military time which is a 24 hour format) (Figure 16).
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& C:EmcapStore’Logs

File Edit Wiew Favorites Tools Help | :;’
o back o B4 7 T | - search Folders | B E
Address I:_‘] C\EmcapStoreilogs _'J = =
Mame = I Sizel Tvpe I Date Modified | Aktriby =
File and Folder Tasks ES 2009020872229, Ext 1EE  Text Document 218/2009 11:29 PM &
j Mk & v Eoider 20090208T2230,kxt 1 KB Text Docurment Z218J2009 11:30PM 1!
E] 20090208T2231 . kxt 2KBE Text Docurnenk 21812009 11:32 PM 4
Q E\';'bgs"' this Felder ko the 2] 2009020972101 bt 2KE Text Document 2/9(2009 10:01 PM A
s = =l 2009020972102 bxt 2ZKE  Text Document 2/9/2009 10:02 PM &
k! Share this Folder %
20090209T2104, kxt 15,181 KB Text Document 21912009 10:43 PM s
E] 20090209T2221 . kxk 15,181 KB Text Document 2/10/2009 12:11 AM s
Other Places & =1 2009021071514, kxt 2KBE Text Docurnent 2110/2009 4:14 PM o
=1 20090210T1520.kxk 2KBE Text Docurnenk 21102009 4:21 PM 4 L
I=) EmcapStore 2009021071803, bxt 2KB  Text Document 2/10/2009 7:03 PM &
D My Docurnents E] 20090211T2153.txk 2FKE  Text Document Z2/11/2009 10:53 PM &
3 My Computer =l 2009021 172324 bt 15,181 KB Text Document 2i12/z009 1:01 &M A
"} My Metwark Places 20090212T1557 . kxt 2KBE Text Docurnenk 21122009 .57 PM s
20090212T1558. kxt 15,121 KB Text Docurnent 21122009 535 PM 4
E] 20090213T1202.kxk 2KB Text Docurnenk 21132009 1:02 PM 4
Dol ¥ =] 20090213T1207.txt 356 KB Text Document 2/13/2009 1:08 PM &
=1 20090216T1607 . kxt 1 KE Text Document 2116/2009 5:07 PM &
20090216T1608. kxk 1 KE Text Document Z116/2009 5:03 PM I
E] 20090216T1615.kxt 718 KE Text Docurment 2116/2009 5:17 PM 4
=l 20090216T1656.xt 12,671 KB Text Docurnent 2116/2009 6:38 PM o
Locate your job = 20090217T1736.bxt 7IGKE Text Document 2{17/2009 6:39 PM A
and double click 2009021 7T1538, kxt 75KE  Text Document FTIZO09 TEEFM A
on. file \ [£] 2009071 7T 1547 but £,.485 KR Text Docoment 1171009 505 PR &
| 2009021771909, Ext 2,927 KB Text Document 2172009 320 PM A |
L.E_J 20090217T2035. kxt 1 KB Text Document 21172009 335 PM 4
20090217T2048. kxt 2,926 KB  Text Docurnent 21172009 .55 PM 1
r[%] 200902181152 bxt 978 KB  Text Document 2182009 1255 PM & -
] | B

Figure 16. Processing Log

Locate the job you want to view and double-click on it to open.

Scroll to the bottom of the page. The number of messages added will be displayed . You can view, save,
print or exit the log file by selecting the File menu on the toolbar and choosing the action.

A

cal with Id 57.|Messages added: 1514 Messages|Removed: O Problem Messages: 1

dordmz. Tocal

Kl
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Reports

There are currently five reports available to the Administrator that can be viewed and exported. These

reports include:

e Message counts

e Account Details by Person

e Account Details by Unit, then by Person

e Conversion Errors

e Conversion Errors, excluding XML Character Issues
To open these reports, select File 2 Reports Menu from the toolbar. The Reports window will appear.
Brepots )

Reports Menu

Choose which accounts to include

" Selected account
jane_doe{@mail testdomain.com

" All accounts within the selected domain.
Test Domain (mail testdomain.com)

&+ | All accounts in all damains |

Filter Options

Include: | * All Accounts © Only Open Accounts © Only Closed Accounts

I™ Include anly thase registered after: | Fricay by 0g 20049 _v]

Choose one of the following report types.

Message Counts |

Account Details: B Person | By Unit, By Fersan

Conwversion Errors | Conwversion Errars, excluding =hdl
Character |ssues

Close |
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Select the account(s) to include in the report and the appropriate filter options. Then choose the report
type by selecting the appropriate button. The report will be generated on the screen.

[-[=]x]

ERET.. & der-sv3m derdmzocal .8 x
F 8 T oo« r W o2 MR-

I Main Report |

Message Counts 3244200

Personllame MessageCount  LastProcessed Status Account

Citizen Affairs
Agency Community and Citizen Affairs
Dormain Narne: governor.emcap ncdcr.gov

Accounts
ArchivesGovOfiice 39071 219/2008  2:57:38AM ReadWWrite archivesgovoffice

Total Messave Count; 39,071

urrert Page Now: | ) [Total Page No.: 1 [Zoom Factor: 100% |
‘ 4
I = | |ol@

When you are finished reviewing the report results, you can either close the report (note that the
information will not be saved) or export the report to another location.

To export to another location, select the export report icon located in the upper left corner of the screen

(Figure 17).
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Eroe — E] oG e o = - A

Message Counts

3/24/2003

PersonMame MessaneCount  LastProcessed Status Account

Citizen Affairs

Agency: Community and Citizen Affairs
Domain Mame: governoremcap.neder gov

Accounts
ArchivesGovOffice 39,071 2A19/2008 2:57:3BAM ReadyVrite archivesgovoffice

Total Message Count: 39,071

Figure 17. Export icon

An Export Report window will appear. Browse to the location you want to save the report, the field
name and file format. Select the Save button.

Where you want to export to

Ll Export Repork
5 .-!"-—' _ .
Save in: |E ot on "SACT03051013007 [10.29.193.143) [Ij a ﬁ o .-=

arcgis I WINDOWS

)Program Files

!l T{r ] [=iPythanzs

iy Cormputer

[ s E

Cancel

ot

%
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If the export was successful, an Export Report window will appear.

Expotrt Report I

L]
“1') Export completed.

Select OK and then close out of the report.

Exiting the Admin Console

When you are finished using the Admin Console, you will need to close out of it and log off the remote
desktop.

To close the Admin Console, either click the close (x) button in the upper right corner of the window or
alternatively from the toolbar, select File - Exit.

To log off of the remote desktop, select the Start button on the toolbar and select the Log Off button

—.

at the bottom of the window. A Log Off Windows window will appear confirming log off.
Select Log Off.
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Technical Definitions

Archival (or collecting) Server — the EMCAP application uses hMailServer IMAP server; free, open source

software registered on SourceForge. Archived messages are downloaded from an IMAP server (i.e.,
Microsoft Exchange) and uploaded to the archival message server which is intended to be a long-term
archival store. The mail stored there can be opened and read or downloaded again.

.CSV File (or Comma Separated Values) — a file format that is often used to exchange data between

disparate applications. It contains the values in a table as a series of ASCII text lines organized so that
each column value is separated by a comma from the next column's value and each row starts a new
line. For example: Doe, John, 576-38-9347.

Domain - an organized collection of records (or users) that are associated with one another. For
example, the users listed under the domain name “Secretary of State” are all affiliated with this specific
agency.

DNS (Domain Name System) - a system for converting host names and domain names into IP addresses

on the Internet or on local networks that use the TCP/IP protocol. For example, when a Web site
address is given to the DNS either by typing a URL in a browser or behind the scenes from one
application to another, DNS servers return the IP address of the server associated with that name.

E-mail Client - a software application (such as Microsoft Outlook) installed on a user’s computer that
allows a user to compose, send and receive e-mail messages.

IMAP protocol — Internet Message Access Protocol (IMAP) is a method of accessing e-mail messages that
are kept on a mail server. In other words, it permits a “client” e-mail program to access remote
messages as if they were local. For example, messages stored on an IMAP server can be manipulated
from a desktop computer at home or work station at the office without the need to transfer these
messages back and forth between these computers. The protocol includes operations for creating,
deleting, and renaming mailboxes; checking for new messages; permanently removing messages, setting
and clearing flags; server-based RFC-2822 and MIME parsing and searching; and selective fetching of
message attributes, texts and portions thereof for efficiency. Most e-mail software subscribes to this.

Parsing - separating data and assigning parts of it into one or more variables. Parsing can assign each
word in the data into a variable or can divide the data into smaller parts. Parsing is also useful to format
data into columns.

.PST File (or data file) - when Outlook saves items to your computer, it uses a type of data file called an

Outlook Personal Folders file (.pst). This is a data file that stores e-mail messages and other items on a
user’s computer (versus the server). A .pst file can be assigned to be the default delivery location for e-
mail messages in order to organize and back up items for safekeeping. If the user has a Microsoft
Exchange Server account, all items are usually delivered to and saved on the e-mail server.
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Server - an e-mail server is a computer that manages mail by storing messages, routing messages to
other servers, and generating error messages when things don’t work quite right.

XML (Extensible Markup Language) - a standard to promote sharing information over the Internet by

specifying ways to describe the information's semantic structure and to validate that the structure is
well formed. XML is described as extensible because it is a metalanguage that allows the creation of tags
to be used for semantic markup. The greatest value of XML can be realized through common
vocabularies of tags, so that applications can use those vocabularies to understand documents from
different sources.
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